Back to overview
Resolved
Currently the BTS is down
Jun 19, 2026 at 1:22am UTC
Affected services
Core layer
Resolved
Jun 20, 2026 at 6:20am UTC
The BTS is now online and stable on connenion
If you guys face any type of problem please remember to remind us!
Affected services
Created
Jun 19, 2026 at 1:22am UTC
The BTS is down due to heavy rain and therefore we Having network issues
A field engineer has been assigned To look after BTS
Affected services